WordPress 3.5 Upgrade – Probleme mit leerem Posteditor

Wordpress
Wordpress

WordPress ist eine tolle Sache, aber nicht immer funktionieren die Updates, wie sie sollen!

Nachdem ich, mutig wie ich bin, das Upgrade auf WordPress 3.5 in meine Blogs eingespielt habe, dachte ich erst, es sei alles problemlos verlaufen. Nachdem ich dann aber einen älteren Post nach dem Upgrade editieren wollte, bekam ich nur eine leere Fläche im Post-Editor anstelle meines Textes gezeigt. Ich habe daraufhin ein bisschen die Foren durchstöbert und siehe da: Es gab noch andere, die das Problem auch hatte. Die erste Übergangslösung für das Problem ist das Einfügen von dieser Zeile in die wp-config.php:

define('SCRIPT_DEBUG', true);

Damit lief erstmal wieder alles, aber ich hatte gelesen, dass man das nicht ewig so lassen sollte, da es erheblich mehr Datenverkehr erzeugt als wenn man WP ohne diese Zeile laufen läßt. Nachdem also der Post geändert war, habe ich mich mal wieder auf die Suche nach einer endgültigen Problemlösung gemacht.
Einige Benutzer haben geschrieben, dass das Plugin BPS – Bullet Proof Security sowas erzuegen könnte. Einige Benutzer hatten das Plugin mal laufen gehabt und da es auch die .htaccess Datei verändert, waren diese Änderungen auch noch aktiv, nachdem das Plugin schon längst deaktiviert war. Man solle die htaccess Datei also mit dem Standard-Code von WordPress füllen:

# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>

# END WordPress

Nachdem auch das erledigt war, lief die Sache bei mir leider immernoch nicht. Ich bekam so langsam das Gefühl, dass ich wieder die grosse Ausnahme bin, wo wieder alles anders ist als bei anderen. Um ganz sicher zu gehen, habe ich zum Testen nochmal alle Plugins deaktiviert (dazu habe ich einfach den Ordner “Plugins” in “-Plugins” umgenannt. Und ich habe das WordPress Default Theme aktiviert, damit ich das Theme auch als Fehlerquelle ausschließen konnte. Das Ergebnis: Immer noch kein Text im Editor-Fenster!

Nun, als letzte Idee habe ich nochmal allgemein nach Fehlern gesucht, die nach der Installation von WordPress 3.5. aufgetaucht sind. Dort habe ich dann einen Eintrag gefunden, der als Lösungsansatz vorgeschlagen hat, einfach nochmal das komplette WordPress per FTP neu hochzuladen. Gesagt getan – und was soll ich sagen: Es lief!

Damit waren die ersten Macken nach dem WP 3.5 Upgrade behoben. Aber ich will es spannend machen: Es wird noch einen Beitrag zu dem Thema geben. Denn heute hatte ich wieder ne schöne Macke gerfunden. Aber dazu demnächst etwas mehr! 🙂

Sir Apfelot auf SteadyHQ unterstützen

1 Kommentar

  1. […] von WordPress – auch wenn mich das letzte WordPress-Update ordentlich Nerven gekostet hat (siehe hier und hier). Entsprechend oft nutze ich es für eigene Projekte oder auch für Kundenseiten. Das CMS […]

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.